Import-Export Tab


Figure 272: Import/Export tab

The Import/Export tab provides ways to get data in and out of Maltego as well as backing up configuration files and importing new ones.

Import Graph from Table

Figure 273: Import graph from table

Overview

Clicking Import graph from Table will open a wizard that will allow you to Import a Graph from a Table structured format. This involves selecting an input file, mapping columns of the input file to entities and creating links between entities. The information that defines a mapping is known as a mapping configuration and the wizard allows you to save and load existing mapping configurations.

Select a file

If you have multiple files with the same structure, then you can select multiple files to import at once.

First choose whether you want to create a new mapping configuration or load a saved one. By default, the most recent saved mapping configuration will be chosen.

Clicking the Manage button will bring up the Mapping Manager window which shows a table of all the currently saved mapping configurations. Mapping configurations are saved according to their name which must be unique. The name and description of a saved mapping configuration can be edited by clicking the edit icon (black arrow below). Mappings can also be deleted by clicking the corresponding delete icon (red arrow below).

After choosing a new or existing mapping configuration, choose the file to be imported and click on Next>.

Note: When loading a saved mapping configuration, Maltego will alert you if the selected mapping is not compatible with the data-file selected.

Connectivity Options

Select how you would like your imported items to be connected. 

The different options are:

  • Meshed: All entities are connected to each other.
  • Sequential: Each entity is connected to the previous one in the order of the columns.
  • Tree: All entities are connected to the first entity.
  • Manual: No links are automatically created.

Mapping Configuration

In this step the user is presented with four tabs which separate mapping configuration creation into four logical processes. At least one entity needs to be defined in the Map Columns to Entities tab, and for two or more defined entities you can create and edit links between them (Connectivity Table tab) and/or assign link properties to input file columns (Map Columns to Links tab).

Note: If a saved mapping configuration was chosen in the Select File step, the entities, links and column mappings would be pre-configured for this step.

Map Columns to Entities tab

Entity mapping is performed by completing three steps for each entity that will be mapped.

You can tell Maltego to treat the first row of the data differently to the rest.

  • Row is Headers: Don't use the row's data when importing
  • Row is Types: The row contains the entity type for that column. E.g. maltego.Person

Select one or more ‘unmapped’ columns , then the entity to which the selected columns are mapped must be selected from the Map to list.

Tip: To add or remove a column from the selected entity hold down Ctrl and click on the column.

Once an entity has been chosen, the property to which each column maps can be edited in step 3.

Steps 1 to 3 are repeated for each entity that should be mapped.

Connectivity Graph Tab

Maltego will automatically generate links between newly mapped entities in the Map Columns to Entities tab. These can be viewed and deleted or additional links can be created in the Connectivity Graph Tab. Create new links by clicking on one entity and dragging your mouse to another.

Tip: Multiple links can be selected by holding down Ctrl or Alt and dragging the mouse across the graph to create a selection box.

Figure 274: Connectivity tab

Connectivity Table

The Connectivity Graph and Connectivity table are both used to define the relationships between imported entities. The connectivity table, provides a table of checkboxes. The checkboxes can be checked and unchecked to create relationships between the entities.

The results of any changes made in the Connectivity Table can be viewed in the Connectivity Graph and visa versa.

The steps for mapping columns to links are the same as the steps for mapping columns to entities, the only difference being that the Map to combo box will present the list of links (created in the Connectivity Graph/Table tab) as opposed to entities.

Settings

After the mapping configuration, has been defined, the wizard presents a Settings screen where various tabular import settings can be set such as sampling, empty values, graph size and link merging. If a current graph exists, you will have the option to merge the imported graph with it. You are also given the option to save the mapping configuration (checked by default) with a default name and description. Mapping configurations are saved with a non-empty, unique name. If the entered name is not unique the existing mapping configuration will be overwritten but a warning will be shown in such cases.

If you choose not to save the mapping configuration, Maltego will save it automatically as Auto-saved mapping — overwriting the existing auto-saved mapping configuration if it exists.

Note: When the Auto-saved mapping is loaded in the Select File step, the default name will be blank forcing you to define a more descriptive name.

Import

If the import has failed, the wizard will inform you and give as much information as possible about the problem. If the import completed successfully a summary of the import result is presented which include the name under which the mapping configuration has been saved.

Figure 275: Import complete

Tabular Mappings

Figure 276: Mappings – Tabular Import Button

Clicking the Mappings – Tabular Import up the Mapping Manager window which shows a table of all the currently saved mapping configurations. The name and description of a saved mapping configuration can be edited by clicking the edit icon (black arrow below). Mappings can also be deleted by clicking the corresponding delete icon (red arrow below).

Export Graph to Table

Figure 277: Export Graph to Table Button

The Export Graph to Table option allows you to export your graph into a tabular format. Clicking the Export Graph to Table button will open the Graph Export Wizard:

Figure 278: Graph export wizard - Step 1

The first step of the graph export wizard is to decide whether to export the whole graph or to just export the selected portion of the graph. There is also the option to choose to remove duplicate rows. A duplicate row would occur when there are 2 links that connect the same two entities.

Clicking Next> will lead to the second step in the wizard where the filename and file type can be chosen for the export:

Figure 279: Graph export wizard - Step 2

From the Files of Type field the file type for the table can be chosen from CSV, XLS or XLSX.

Figure 280: Export table file types

Clicking Next> will export your graph to the chosen format. Once the export is complete there will be a summary page that shows everything that was exported to the tabular file:

Figure 281: Export graph to table – Summary

Export Graph as Image

Figure 282: Export Graph as Image Button

As the name suggest, Export Graph as Image will export a Maltego graph to an image format. Clicking the Export Graph as Image will open the following window:

Figure 283: Export graph as image

The file type to can be chosen for the File of Type dropdown field. Image file types can be chosen from png, jpeg, bmp.

Figure 284: Image file types

The image scale can also be chosen as a number between 100% and 500% from the Scale image dropdown field.

Figure 285: Export image scale

The higher this number is, the higher the resolution of the exported image will be. Keep in mind that with large graphs a high image scale can result in very large image files.

Once these options have been chosen, clicking the save button will save a copy of your graph to the selected image format.

Generate Report

Figure 286: Generate Report Button

The Generate Report button in Maltego creates a pdf report that contains all information about the current graph in a single document. As a Maltego reports will contain all information about your graph, they can end up being very long. (i.e.: a 30-entity graph can easily generate a 20-page report)

Clicking Generate Report will open a save dialog where the filename and location can be provided:

Figure 287: Save Maltego report dialog window

In a Maltego report the following will be included:

  1. Image of the full graph

  2. Top 10 Entities – lists of entities ranked by the following features:

    1. Ranked by Incoming Links

    2. Ranked by Outgoing Links

    3. Ranked by Total Links

  3. Entities by Type - lists of entities categorized by their type.

  4. Entity details – lists each entity and includes all the information from the property view and detail view. The image below shows an example of one item from the Entity detail list:

Figure 288: Entity detail from a Maltego Report

Export Config

Figure : Export Config Button

All custom configurations to a Maltego client can be exported and imported to/from a configuration file that can be used to either back-up your configurations when re-installing your Maltego client or if you wish to share your Maltego configurations with other users.

When exporting custom configurations, the following can be exported:

  • Transform hub item - this will include all transform hub items that are installed the Maltego client. Note: the export will not include API keys that are stored in installed transform hub items.

  • Entities – Custom and/or installed entity types that are defined in the Maltego client.

  • Local Transforms – this will export the Maltego configuration for local transforms. Note: local transform scripts need to be backed up separately.

  • Transform sets

  • Views

  • Icons

  • Services

  • Tabular mappings

Clicking the Export Config button will open the Export Wizard. To complete the Export Wizard, similar steps to Export Entities can be taken. The only difference is that in the second step of the wizard all the items listed above can be chosen for the export:

Figure 290: Choose configurations to be exported

Import Config

Figure : Import Config Button

All configuration listed in the Export Config section can be imported to a Maltego client from a .mtz file format. Similar steps described in the Import Entities section can be followed to import a Maltego configuration file.

Continue to the Windows Tab page.



© Copyright 2017, Paterva PTY Limited